Cluster problem - Honda CBR250R Forum : Honda CBR 250 Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 2 Old 09-06-2019, 07:01 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Cluster problem

So I just purchased a 2012 cbr 250 r abs with 6k miles on it . Everything works fine. Just othe other day while I was taking my bike to storage because I thought a hurricane was coming, as I was riding I accidentally hit the power switch and now my cluster won’t turn back on. I checked the fuses and they’re fine, and also checked the wires for loose connections. Any suggestions
Jordan6252 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-08-2019, 03:27 PM
Senior Member
 
Schroeder's Avatar
 
Join Date: Mar 2014
Location: Germany
Posts: 1,818
Thanks: 206
Thanked 356 Times in 293 Posts
Hi Jordan,


that is odd. My money would have been on blown fuses too but since you've already checked those I don't know what else it could be.

My computer is fighting Aids and Cancer in it's idle time, and yours?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Schroeder is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda CBR250R Forum : Honda CBR 250 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome