Honda CBR250R Forum : Honda CBR 250 Forums

Honda CBR250R Forum : Honda CBR 250 Forums (https://www.cbr250.net/forum/)
-   CBR250 Problems and Issues (https://www.cbr250.net/forum/cbr250-problems-issues/)
-   -   Turn Signals Not working (https://www.cbr250.net/forum/cbr250-problems-issues/68233-turn-signals-not-working.html)

Grey 08-19-2018 07:37 AM

Turn Signals Not working
 
Model Year: 2013, US model

ABS model?: No

Description of the Problem:

My turn signals are not working. The fronts function just fine as running lights and stay on. My rear lights are gone, and have been replaced by an integrated LED "all in one light". That new LED taillamp had been working just fine, then on a ride recently I lost my cluster and all of the lights. Sure enough, that fuse was blown.

I replaced that fuse and got all of my functionality back EXCEPT for my indicators. The switch on the grip does nothing, and does not light up the dash indicators, but everything else on the drip works (horn, high beam switch)

I have fitted the original turn signals back on the rear: still no function. I have been searching the forums and I found a few ideas, but nothing solid as to what a next step is. The only lead I have is a flasher relay module, but I can't get a solid answer as to whether or not I have one (seems like some threads say that US models don't have it.)

What are some good next steps? And if I do need to try to replace that relay, where is it on the bike? I saw a YT video on a 300 where its under the left fairing, but other threads say near the headlight.

Thanks in advance

CBR Blaize 08-19-2018 09:01 AM

I bet that there is a short on the new tail light. That popped the fuse and probably the blinker relay. As for the tail light I would not use it again without getting a new one. You probably would be able to get a replacement for free if its a reputable company at all.

To get parts I like to use Partzilla. Here is a link to the relay https://www.partzilla.com/product/ho...b28c4765c6a71c

Grey 08-19-2018 02:14 PM

Quote:

Originally Posted by CBR Blaize (Post 683859)
I bet that there is a short on the new tail light. That popped the fuse and probably the blinker relay. As for the tail light I would not use it again without getting a new one. You probably would be able to get a replacement for free if its a reputable company at all.

To get parts I like to use Partzilla. Here is a link to the relay https://www.partzilla.com/product/ho...b28c4765c6a71c

Thanks for that!

ill get in contact with them and see what the process is for getting that taillight swapped.

Where is that relay on the bike and what needs to be removed to access it?

CBR Blaize 08-19-2018 02:27 PM

Quote:

Originally Posted by Grey (Post 683861)
Where is that relay on the bike and what needs to be removed to access it?

On our bike it is on the left side behind the headlight. You can get at it without removing the side fairing but doing so will make it easier.

Grey 09-02-2018 07:37 AM

for anyone that may search this topic later, the relay fixed the issue. It was right behind the front headlight is a rubber grommet. I could access it by reaching up above the front fender.

Thanks!

mark5211 11-27-2018 09:40 PM

This is my fear of buying a "modded" bike with aftermarket turn signals, etc... Odds of having issues go up dramatically with any mods that involve the electrical system. Thanks for sharing.


All times are GMT -4. The time now is 12:42 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome