Fuel issues? - Honda CBR250R Forum : Honda CBR 250 Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 6 Old 07-29-2019, 08:50 PM Thread Starter
Junior Member
 
Mikeg99's Avatar
 
Join Date: Jul 2019
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Fuel issues?

Ok so I have a 2012 cbr250r. It ran fine until I let it set up for a year or so. I know stupid...

So at first it would not crank at all. I took the tank off and played with the pump. Got it working. You can now hear it prime. It will crank and run but after about 10-15 seconds it dies. It will start right back up if I hit kill switch.

Check engine light comes on like right as it cuts off. Not sure if it’s the problem or just coming on cuz it cut off.

Also the fuel gauge flashes full won’t read (not sure if this has anything to do with it)

I took fuel filter off and blew through it so don’t think it’s stopped up.

Just lost at what else to check. Sorry for the long wall of text. Please help 🙂
Mikeg99 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-29-2019, 09:41 PM Thread Starter
Junior Member
 
Mikeg99's Avatar
 
Join Date: Jul 2019
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Wanted to add battery is dead so I’m using a jump start. Not sure if this is doing anything. I would think not jus want to give all information.
Mikeg99 is offline  
post #3 of 6 Old 07-30-2019, 09:03 AM
Senior Member
 
Join Date: Sep 2011
Location: WI
Posts: 1,705
Thanks: 244
Thanked 258 Times in 197 Posts
Dead battery will cause problems, even after it's running.

Before getting into it more, buy a new battery and charge it overnight.

If you haven't drained the tank (assuming gas wasn't stabilized) I would do that before trying again.

Add a strong fuel system cleaner like Techron Concentrate (I know...I know...) at 1oz per gal to the fresh gas. I do that once per season in all my vehicles to clean the intake track and combustion chamber.
jkv357 is online now  
 
post #4 of 6 Old 07-30-2019, 09:34 PM Thread Starter
Junior Member
 
Mikeg99's Avatar
 
Join Date: Jul 2019
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
I did drain the tank but I did not put fuel additive. I will do that.

Also have just been jumping it off didn’t think that would matter but I will get a new battery and try that. Hopefully that’s my problem.
Mikeg99 is offline  
post #5 of 6 Old 07-31-2019, 09:55 AM
Senior Member
 
Join Date: Sep 2011
Location: WI
Posts: 1,705
Thanks: 244
Thanked 258 Times in 197 Posts
Quote:
Originally Posted by Mikeg99 View Post
I did drain the tank but I did not put fuel additive. I will do that.

Also have just been jumping it off didn’t think that would matter but I will get a new battery and try that. Hopefully that’s my problem.
There may still be bad fuel in the line and injector that may take time to move through.

The cleaner will help dissolve any varnish in the system from the old gas, and will eventually clean the injector if it's not too gummed-up.
jkv357 is online now  
post #6 of 6 Old 07-31-2019, 05:35 PM Thread Starter
Junior Member
 
Mikeg99's Avatar
 
Join Date: Jul 2019
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Definitely will do that. I I’ll get a battery and fuel cleaner and hopefully will help my issue. Thank you
Mikeg99 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda CBR250R Forum : Honda CBR 250 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome