Honda CBR 250 Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1 (Edited)
Hi Ladies & Gentles,
Im encounter my cbr250r 2011 Nov instrument panel blue back light off (engine heat side) since last week. Now only the fuel level side light on.

It is somebody face same issue & how the solution?:confused:
 

·
Registered
Joined
·
381 Posts
That is an el panel backlight. If it is not working, its probably down for the count. Get a warranty replacement.
 

·
Registered
Joined
·
237 Posts
I would have the dealer contact Honda and see if Honda will replcae as a goodwill gesture.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7 (Edited)
Meter modified. I placed white LED stripe behind the LCD display.
Now my blue color backlight brighter, very satisfied.
The backlight plastic sheet is blue color, so if u want purple look u can put red LED stripe.

Attached pic shown 3/4 from right brighter bcoz my LED stripe too short & 1/4 from left is original color.
Seem the selected LED stripe not suitable, will find the better later.
 

Attachments

·
Registered
Joined
·
14 Posts
Meter modified. I placed white LED stripe behind the LCD display.
Now my blue color backlight brighter, very satisfied.
The backlight plastic sheet is blue color, so if u want purple look u can put red LED stripe.

Attached pic shown 3/4 from right brighter bcoz my LED stripe too short & 1/4 from left is original color.
Seem the selected LED stripe not suitable, will find the better later.
hi there,

can you please provide us with a little more details on the LED and the installation?
my lcd went fully dark yesterday!

thanks
 

·
Registered
Joined
·
14 Posts
Sounds like I should bookmark this thread for the future...

yah i did so too. the problem is very annoying as i drive through mountains and deserts in Oman and it's very dark and i cant see the fuel or speed :(

did so much research on the lcd strips i could use but so far no luck. hope someone can help us soon.


thanks
 

·
Registered
Joined
·
30 Posts
What if its flickering on and off? LEDs are completly toast when gone right?
I just want to make sure before I check with Honda for my warranty & or start messing with stuff. My initial guess is a loose plug
 

·
Registered
Joined
·
2 Posts
Solution!

Guys, ive encountered same problem as you all.
my Blue back light flickers and sometimes it shut off completely. ive checked to my local technician they say it doesnt appear to have any problem. it fixed for awhile until it turns back on me.

so just now after i washed the bike myself i try to give pressure to some rubber parts riget bellow the back light(note that i didnt take off any fairring i just put my hand in and give pressure to some part while i turn on the bike.) . so in the end i my conclusion was the blue back lid cable was loose for some reasson, you guys should try this out!
put your hands in bellow the speedometer youll find some tight rubberry thing, press it while turning the lights on so you adjust the cable. or dissamble it completely to re adjust the loose cable approphiately.
 

·
Registered
Joined
·
41 Posts
Guys, ive encountered same problem as you all.
my Blue back light flickers and sometimes it shut off completely. ive checked to my local technician they say it doesnt appear to have any problem. it fixed for awhile until it turns back on me.

so just now after i washed the bike myself i try to give pressure to some rubber parts riget bellow the back light(note that i didnt take off any fairring i just put my hand in and give pressure to some part while i turn on the bike.) . so in the end i my conclusion was the blue back lid cable was loose for some reasson, you guys should try this out!
put your hands in bellow the speedometer youll find some tight rubberry thing, press it while turning the lights on so you adjust the cable. or dissamble it completely to re adjust the loose cable approphiately.
Thanks for your ideas. I think the dashboard has a total of 3 of those blue backlights. My bike is just over 2 years old and all 3 of my blue dashboard lights are flickering on and off when I drive. They seem to only flicker one at a time, but are always changing. I will try what you suggested. Good advice. Thanks.
 

·
Registered
Joined
·
13 Posts
Same problem here with the bike I just bought on 8/9/14. Looks like I'll have to try what Rayman suggested.
 

·
Registered
Joined
·
2 Posts
The LED Backlit

Hey Guys, After a few month using my own suggestion. my LED died for good eventually. The only way i fix it, is to bring the speedometer to an electrical work shop or take the speedo circuit to some one understands curcuits(so you need to un assemble the speedo from the bike first). so they say i need to change the LED in the circuit. by then you are pick the led colour as well.
it needs more effort than i thought, just becarefull not to brake it guys.
Thank you for you attention!
 
1 - 19 of 19 Posts
Top